const regex = /\[highlight](.*?)\[\/highlight]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[highlight](.*?)\\[\\\/highlight]', 'gm')
const str = `[highlight][b]xxxxxx[/b][/highlight]
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);