Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?:(?:\+|00)33[\s.-]{0,3}(?:\(0\)[\s.-]{0,3})?|0)[1-9](?:(?:[\s.-]?\d{2}){4}|\d{2}(?:[\s.-]?\d{3}){2})$
/
gm
Test String
New
~ Accepted ~ 0123456789 01 23 45 67 89 01.23.45.67.89 0123 45.67.89 0033 123-456-789 0033(0)123456789 +33-1.23.45.67.89 +33 - 123 456 789 +33(0) 123 456 789 +33 (0)123 45 67 89 +33 (0)1 2345-6789 +33(0) - 123456789 -------------------------------- ~ Rejected ~ 012345678 01234567890 0+123456789 (0)123456789 01 23 45 67 89 -------------------------------- ~ Accepted but strange ~ +33.-.123456789 +33.-.(0)-.-123456789 01 23.45-67.89