#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:\D)*(?:(\d{1,3})\/)?(?:(\d{1,3})\/)?(\d{1,3})\/(\d{1,3})$"
Local $sString = "1/1/1" & @CRLF & _
"XDSL 1/1/1/1" & @CRLF & _
"XDSL Port 1/1/1/1" & @CRLF & _
"Port 1/1/1/1" & @CRLF & _
"Anytext 1/1/1/1" & @CRLF & _
"XDSL 1/1/1" & @CRLF & _
"XDS 1/1" & @CRLF & _
"1/1/1/1" & @CRLF & _
"ABC 1/1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")