package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?:\D)*(?:(\d{1,3})\/)?(?:(\d{1,3})\/)?(\d{1,3})\/(\d{1,3})$`)
var str = `1/1/1
XDSL 1/1/1/1
XDSL Port 1/1/1/1
Port 1/1/1/1
Anytext 1/1/1/1
XDSL 1/1/1
XDS 1/1
1/1/1/1
ABC 1/1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}