use strict;
my $str = '1/1/1
XDSL 1/1/1/1
XDSL Port 1/1/1/1
Port 1/1/1/1
Anytext 1/1/1/1
XDSL 1/1/1
XDS 1/1
1/1/1/1
ABC 1/1';
my $regex = qr/^(?:\D)*(?:(\d{1,3})\/)?(?:(\d{1,3})\/)?(\d{1,3})\/(\d{1,3})$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}