const regex = /^(?:\d{5,8}_)+\d{5,8}_?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{5,8}_)+\\d{5,8}_?$', 'gm')
const str = `123456_123456
12345678_12345678_12345678
123456_12345678_123456_12345678
12345_123456_1234567_12345678_
1234567_
123456_1
123456_12
123456_1594126781
123_1594126781`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}