using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)Ran Apply\b(?:.+?(\*\*Apply Error\*\*)|.*)";
string input = @"Ran Apply for dir: `some random path/something/something`
`**Apply Error**`";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}