// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)Ran Apply\b(?:.+?(\*\*Apply Error\*\*)|.*)").unwrap();
let string = "Ran Apply for dir: `some random path/something/something`
`**Apply Error**`";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}