using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^aeiouy]*)([aeiouy]?)(\S+)(\s+)";
string substitution = @"\2\3\1ay ";
string input = @"the quick brown fox jumps over the lazy dog ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}