import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*product_attribute_2.*?|option value=\"(\\d+)\"|<\\/select>.*";
final String string = "<select id=\"product_attribute_1\">\n"
+ " <option value=\"1\">2.2 GHz</option>\n"
+ " <option selected=\"selected\" value=\"2\">2.5 GHz</option>\n"
+ "</select>\n"
+ "<select id=\"product_attribute_2\">\n"
+ " <option value=\"3\">2GB</option>\n"
+ " <option value=\"4\">4GB</option>\n"
+ " <option value=\"5\">8GB</option>\n"
+ "</select>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}