#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(0?[1-9]|[12]\d{1}|3[01]])[\/|\.|-](0?[1-9]|12|11)[\/|\.|-]\d{1,4}\b"
Local $sString = "Bắt các chuỗi ngày tháng này" & @CRLF & _
"12/01/2017" & @CRLF & _
"15/2/2017" & @CRLF & _
"3/03/2018" & @CRLF & _
"12/24/2018" & @CRLF & _
"1.1.2018" & @CRLF & _
"7-9-18" & @CRLF & _
"1.31.2018" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Không bắt các chuỗi như thế này, vì không đúng ngày tháng" & @CRLF & _
"123/2/1234 13/ab/3346 12/223/12 60/60/2018 32/12/2018" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")