re = /^\D*(?:\d+\D+){2}$/m
str = 'There were 3 cars going over 45 miles per hour'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end