# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^6.102$"
test_str = ("Match ENTIRE LINE of these lines:\n\n"
"6.102\n"
"6.00\n"
"6.341\n"
"17.006\n"
"15.0341\n\n"
"and NONE of these:\n\n"
"6005\n"
"128.2.34.101\n"
"NO.DONT\n"
"6.5X0\n"
"OU.812")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.