package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z][a-z]*)(\d*[-+]?)`)
var str = `K+
Cr7+
O2-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}