$re = '/(?<century>1[2-9]|2[0-2])(?<year>\d{2})/m';
$str = 'validates years 1200-2299 into century (first two digits of the 4 digit year and year (last two digits).
1177
1200
1359
1492
1522
1621
1776
1872
1996
2050
2199
2245
2381';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);