$re = '/.+?\]/m';
$str = '[\'210\', \'210\', \'210\', \'210\'][\'0.3\', \'0.3\', \'0.3\', \'0.3\'][\'7.85e-06\', \'7.85e-06\', \'7.85e-06\', \'7.85e-06\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);