$re = '/^\d+\s?,\s?\d+$/m';
$str = '5, 7
2,2
7 , 7
534 ,23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);