package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(-?\d+(?:\.\d+)?),\s(-?\d+(?:\.\d+)?),\s(-?\d+(?:\.\d+)?)]`)
var str = `[-34.0, 23, 0.555] , [3, 4, 5], ....`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}