re = /\[(-?\d+(?:\.\d+)?),\s(-?\d+(?:\.\d+)?),\s(-?\d+(?:\.\d+)?)]/m
str = '[-34.0, 23, 0.555] , [3, 4, 5], ....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end