using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<startwort>AB[\w\d]+[a-zA-Z]*)\s+(?<startplus>(AB[\d][\w\d]+[-A-Z]{0,3},{0,1}\s+)*)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>[a-zA-Z0-9_üöä]+)\s+(?<betrag>[\d.,]+)\s*$";
string input = @"AB2001482 AB0783714, AB0783714-QR, ABBILD NRRHLAT 10 XäZ 207,25";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}