package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<startwort>AB[\w\d]+[a-zA-Z]*)\s+(?<startplus>(AB[\d][\w\d]+[-A-Z]{0,3},{0,1}\s+)*)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>[a-zA-Z0-9_üöä]+)\s+(?<betrag>[\d.,]+)\s*$`)
var str = `AB2001482 AB0783714, AB0783714-QR, ABBILD NRRHLAT 10 XäZ 207,25`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}