$re = '/^(?<startwort>AB[\w\d]+[a-zA-Z]*)\s+(?<startplus>(AB[\d][\w\d]+[-A-Z]{0,3},{0,1}\s+)*)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>[a-zA-Z0-9_üöä]+)\s+(?<betrag>[\d.,]+)\s*$/';
$str = 'AB2001482 AB0783714, AB0783714-QR, ABBILD NRRHLAT 10 XäZ 207,25';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);