import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^([0-9[:punct:]0-9]+|\\p{No}|\\d\\p{No}) ?\\s* ?([0-9[:punct:]0-9]+|\\p{No}|\\d\\p{No})* ?\\w* (cup|tsp|tbps|tablespoon|teaspoon|small|medium|pint|ounce|pound))|(^(small|Large|medium|Fresh))";
final String string = "Should match:\n"
+ "1 Cups\n"
+ "2 tsp\n"
+ "3 tbps\n"
+ "1/2 tablespoon\n"
+ "3 tablespoons\n"
+ "1 tablespoon\n"
+ "3 teaspoons\n"
+ "1 small\n"
+ "Small chiles\n"
+ "23 Small chiles\n"
+ "1/2 a Small chile\n"
+ "1 1/2 cups kewpie\n"
+ "11/2 cups kewpie\n"
+ "1/3 cup fresh lemon juice\n"
+ "1 medium onion\n"
+ "Large\n"
+ "medium\n"
+ "Freshly\n"
+ "1½ cups Kewpie\n"
+ "½ cups Kewpie\n"
+ "1 pint\n"
+ "4 ounces\n"
+ "1 pound\n"
+ "2 pounds\n\n"
+ "Should not match:\n\n"
+ "1 Make the sauce\n"
+ "1 toast the bread\n"
+ "I want to make 1 piece of toast";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}