re = /(?<!\S)(?!\*+\d)[a-zA-Z]*\*[a-zA-Z*]*/x
str = '(A) Match these:
*** star* st**r
(B) Not these:
800*m *4,500
(C) And not these:
800**m **4,000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end