# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
#https://www.native-english.ru/grammar/english-nouns-plural
(?<![a-z]) #word boundary
(?: [a-z]+ [bcdfghjklmnpqrtvwzeoya]s
| [a-z]+ (?:[sc]h|[sxoiv])es
| children|men|women|mice|teeth|feet|geese|oxen|deer|sheep|swine
)
$
"""
test_str = ("area\n"
"areas\n\n"
"child\n"
"children\n"
"man\n"
"men\n"
"woman\n"
"women\n"
"mouse\n"
"mice\n"
"tooth\n"
"teeth\n"
"foot\n"
"feet\n"
"goose\n"
"geese\n\n"
"ox\n"
"oxen\n\n"
"deer\n"
"sheep\n"
"swine\n\n"
"cat\n"
"cats\n"
"bus\n"
"buses\n"
"moon\n"
"moones\n\n"
"class\n"
"classes\n"
"box\n"
"boxes\n"
"bush\n"
"bushes\n"
"inch\n"
"inches\n"
"match\n"
"matches\n\n"
"shelf\n"
"shelves\n"
"wive\n"
"wives\n\n"
"chief\n"
"chiefs\n"
"roof\n"
"roofs\n"
"safe\n"
"safes\n\n"
"army\n"
"armies\n"
"city\n"
"cities\n"
"employee\n"
"employees\n\n"
"day\n"
"days\n"
"toy\n"
"toys\n"
"boy\n"
"boys\n\n"
"hero\n"
"heroes\n"
"potato\n"
"potatoes\n"
"tomato\n"
"tomatoes\n\n"
"solo\n"
"solos\n"
"radio\n"
"radios\n"
"photo\n"
"photos\n"
"piano\n"
"pianos")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL | re.VERBOSE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.