use strict;
my $str = '1616846098450
trying : 16633299966633299966633299
0x4d68c66a4b7ac51f87e22d0e0b70a4ebc7f6286e7834ec3da18c6147f578afe8
wtf
0x848fcea771facf657677f1f3a919ab7e43b1f7d0df95bf8375113c5621e063c2
';
my $regex = qr/0[xX][0-9a-fA-F]+(?=\nwtf)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}