#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?U)\[:fr\](\D*)\[:\]"
Local $sString = "[:fr] French title [:][:en] English title [:]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)