package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)\[:fr\](\D*)\[:\]`)
var str = `[:fr] French title [:][:en] English title [:]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}