use strict;
my $str = '[:fr] French title [:][:en] English title [:]';
my $regex = qr/\[:fr\](\D*)\[:\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";