import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href.+?[\\'|\\\"]+?([^\\'|\\\"]+)?[\\'|\\\"]";
final String string = "<a href='http://matrix.ms.com/\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ\">Matrix.ms.com</a>\n"
+ "<a href=\"http://matrix.ms.com/\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ\">Matrix.ms.com</a>\n\n"
+ "a.+?href.+?[\\'|\\\"]+?([^\\'|\\\"]+)?[\\'|\\\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}