re = /href.+?[\'|\"]+?([^\'|\"]+)?[\'|\"]/m
str = '<a href=\'http://matrix.ms.com/" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ">Matrix.ms.com</a>
<a href="http://matrix.ms.com/" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ">Matrix.ms.com</a>
a.+?href.+?[\\\'|\\"]+?([^\\\'|\\"]+)?[\\\'|\\"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end