use strict;
my $str = '<meta itemprop="duration" content="PT103M0S">
<meta itemprop="duration" content="PT0M58S">
<meta itemprop="videoId" content="3elGSZSWTbM"><meta itemprop="duration" content="PT18M51S"';
my $regex = qr/duration\" content=\"PT(?<minutes>\d+)M(?<seconds>\d+)S/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}