import Foundation
let pattern = #"duration\" content=\"PT(?<minutes>\d+)M(?<seconds>\d+)S"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<meta itemprop="duration" content="PT103M0S">
<meta itemprop="duration" content="PT0M58S">
<meta itemprop="videoId" content="3elGSZSWTbM"><meta itemprop="duration" content="PT18M51S"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)