package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^data(-[^:]*)*$`)
var str = `data-crash-crash-crash-crash-crash-crash-crash-crash-crash-crash-crash-crash-crash:c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}