import re
regex = re.compile(r"(\pL+)(\d+)", flags=re.MULTILINE)
test_str = ("Форд23324\n"
"Форд23325\n"
"Форд23326\n"
"Форд23327\n"
"Форд23328\n"
"Форд23329\n"
"Форд23330\n"
"Форд23331\n"
"Форд23332\n"
"Форд23333\n"
"Форд23334\n"
"Форд23335\n"
"Форд23336\n")
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)