// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\pL+)(\d+)").unwrap();
let string = "Форд23324
Форд23325
Форд23326
Форд23327
Форд23328
Форд23329
Форд23330
Форд23331
Форд23332
Форд23333
Форд23334
Форд23335
Форд23336
";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}