using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(mother|father)(.*?)(?!\1)((?1))";
string input = @"Postive matches:
mother a father
father a mother
father a mother a father
mother a father a mother
something else mother a father a father mother blablö mother and father
not this mother mother or
or father father but this
Non-matches:
just mother
just father
mother then mother
father then father
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}