use strict;
my $str = 'Postive matches:
mother a father
father a mother
father a mother a father
mother a father a mother
something else mother a father a father mother blablö mother and father
not this mother mother or
or father father but this
Non-matches:
just mother
just father
mother then mother
father then father
';
my $regex = qr/(mother|father)(.*?)(?!\1)((?1))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}