$re = '/(?:\?\*|\*\?|(\*|\?)\1)+(\*|\?)?/m';
$str = '*?a?s?*?k?i?n?a?r?d?*?*?d?e?d?i?c?a?t?e?d?*?****r?e?g????i?o?n?a?l*';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;