$re = '/(?<!\b)#(?![!]).*/m';
$str = '#!bin/bash
# kom
" # nie kom"
${zmienna#.?}
polecenie #komentarz
polecenie#komentarz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);