Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=\s)(?<start>%%)?%dMODIFIER_PROPERTY_(\w+)%(?(start)|%%)(?=[^%]|$)
/
gm
Input 1
1
New
"DOTA_Tooltip_modifier_viper_poison_attack_slow_Description" "Velocidad de movimiento reducida un %dMODIFIER_PROPERTY_MOVESPEED_BONUS_PERCENTAGE%%%, resistencia mágica reducida un %dMODIFIER_PROPERTY_MAGICAL_RESISTANCE_BONUS%%%. Recibiendo daño a lo largo del tiempo." %%%dMODIFIER_PROPERTY_SOMETHING% %%dMODIFIER_PROPERTY_SOMETHING% %%%%dMODIFIER_PROPERTY_SOMETHING% %%%dMODIFIER_PROPERTY_SOMETHING%% %%%dMODIFIER_PROPERTY_SOMETHING%%% %dMODIFIER_PROPERTY_SOMETHING% %dMODIFIER_PROPERTY_SOMETHING%% %dMODIFIER_PROPERTY_SOMETHING%%% %dMODIFIER_PROPERTY_SOMETHING%%%%