const regex = new RegExp('(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\\s(?P<content>(^#(| .*)$\\s)+)^# ///$
', 'gm')
const str = `# /// pyproject
# [run]
# dependencies = ["requests<3"]
# ///
#
# This data is still being read
# if someone has accidentally bridged
# two metadata blocks without a blank
# line or other data between them this
# will be included.
#
# /// pyproject
# You might expect this to be a second
# pyproject block and cause an error but
# instead it will be picked up by the regex
# all as one block.
# ///
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}