const regex = /(?<header_all>
^
(?<!\\)
(?<header_level>\#+)
[ \t]*
(?<header_content>.*?)
[ \t\#]*
(?<!\\)
\{
[[:blank:]\h]*
(?<header_attr>[^\}]*)
\}
\n
)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<header_all>
^
(?<!\\\\)
(?<header_level>\\#+)
[ \\t]*
(?<header_content>.*?)
[ \\t\\#]*
(?<!\\\\)
\\{
[[:blank:]\\h]*
(?<header_attr>[^\\}]*)
\\}
\\n
)', 'gm')
const str = `### Header {#id3 }
#### Header ## { #id4 }
### Header {.cl }
### Header {.cl .class }
### Header {.cl.class#id7 }
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}