$re = '/(?<header_all>
^
(?<!\\\\)
(?<header_level>\#+)
[ \t]*
(?<header_content>.*?)
[ \t\#]*
(?<!\\\\)
\{
[[:blank:]\h]*
(?<header_attr>[^\}]*)
\}
\n
)/mxJ';
$str = '### Header {#id3 }
#### Header ## { #id4 }
### Header {.cl }
### Header {.cl .class }
### Header {.cl.class#id7 }
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);