using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<partnumber>\d{4}\.\d{3}\.\d{3})\s+(\d+)\s+(\d+)\s+(\d+\,\d+)\s+(\d+)\s+(\d+\,\d+)\s+(.*?)\sHS\.code: (\d+) Country of origin: ([A-Z\/]+)";
string input = @"11 4149.310.025 000 1 37,78 1 37,78
PISTON
HS.code: 87084099 Country of origin: EU/DE
EAN: 2050000141478
21 0734.401.251 000 4 3,05 1 12,20
PISTON RING
HS.code: 73182100 Country of origin: JP
EAN: 2050000026638""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}