import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<partnumber>\\d{4}\\.\\d{3}\\.\\d{3})\\s+(\\d+)\\s+(\\d+)\\s+(\\d+\\,\\d+)\\s+(\\d+)\\s+(\\d+\\,\\d+)\\s+(.*?)\\sHS\\.code: (\\d+) Country of origin: ([A-Z\\/]+)";
final String string = "11 4149.310.025 000 1 37,78 1 37,78\n"
+ "PISTON\n"
+ "HS.code: 87084099 Country of origin: EU/DE\n"
+ "EAN: 2050000141478\n"
+ "21 0734.401.251 000 4 3,05 1 12,20\n"
+ "PISTON RING\n"
+ "HS.code: 73182100 Country of origin: JP\n"
+ "EAN: 2050000026638\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}