re = /^exmpl-(?P<type>main|staging|demo|production)(?:-(?P<case>\d+|main))?(?:-(?P<title>(?!e2e-\d+).+?))?(?:-e2e-(?P<timestamp>\d+))?$/m
str = 'exmpl-staging-1234-my-case-title-e2e-1707336983872'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end