import re
regex = re.compile(r"(?P<street>\d+\s.*?(?:,\s*\w*\s*\d+)*),\s*(?P<city>.*?),\s*(?P<state>[A-Za-z]+)\s*(?P<zip>\d+)?,*", flags=re.MULTILINE)
test_str = ("9320 Se Woodstock Blvd, Portland, OR 97266\n"
"921 S E Powell Blvd, PORTLAND, OR 97202\n"
"6560 Sw Beaverton, Raleigh Hills, OR 97225\n"
"2875 Se Powell Blvd, Portland, Or 97202, Usa\n"
"1311 Nw 23rd Ave, Portland, OR 97210\n"
"7710 Sw Barbur Blvd, Portland, OR 97219\n"
"1462 Ne 122nd Ave., Portland, OR 97230\n"
"1831 W Burnside, PORTLAND, OR 97209\n"
"1881 Sw 5th Ave, Portland, OR 97201\n"
"3610 Se Hawthorne Blvd, Portland, OR 97214\n"
"1850 Sw Skyline Blvd., Portland, OR 97221\n"
"9 Centerpointe Dr, Lake Oswego, OR 97035\n"
"7700 Southwest Dartmouth Avenue, 120, Tigard, OR 97223\n"
"4811 Meadows Road , Suite 111, Lake Oswego, OR 97035")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")