$re = '//([a-zA-Z0-9_-]+)[.](css|js)/m';
$str = 'duis ut diam quam /app.css porttitor
app.css
main.js
purus sit (amet volutpat /main.js)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);