// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/([a-zA-Z0-9_-]+)[.](css|js)").unwrap();
let string = "duis ut diam quam /app.css porttitor
app.css
main.js
purus sit (amet volutpat /main.js)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}